First, thank you Brent for you detailed explanations today.
What follows is my configuration which works now with my GL-MT300A (
https://wiki.openwrt.org/toh/gl-inet/gl-mt300a )
The trick part was to figure out how to set the correct vlan on OpenWrt.
It seems it (still) works without mac-address spoofing, but nevertheless I
set it to the same as the provided Fritz!Box (which I am going to return
now)
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fdcc:1234:5678::/48'
config interface 'lan'
option type 'bridge'
option proto 'static'
option netmask '255.255.255.0'
option delegate '0'
option _orig_ifname 'eth0.1 wlan0'
option _orig_bridge 'true'
option ifname 'eth0.1'
option ipaddr '192.168.0.1'
option ip6assign '64'
option ip6hint '1234'
config device 'wan_dev'
option name 'eth0.35'
option macaddr 'xx:xx:xx:xx:xx:xx'
config interface 'wan'
option ifname 'eth0.35'
option _orig_ifname 'eth0.2'
option _orig_bridge 'false'
option proto 'pppoe'
option username 'xxxxxxxx@tango'
option password 'yyyyyyyy'
option mtu '1492'
config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'
config switch_vlan
option device 'switch0'
option vlan '1'
option ports '1 2 3 4 6t'
option vid '1'
config switch_vlan
option device 'switch0'
option vlan '2'
option ports '0t 6t'
option vid '35'
On 26 September 2017 at 13:02, Brent Frère <Brent.Frere(a)abilit.eu> wrote:
I configure routers/firewalls on fibers in Luxembourg,
but using LOL
mainly.
Please call me after 5pm. LiLux number is 20.333.222-99
Le 26/09/2017 à 14:13, Yves Glodt a écrit :
Hi,
I want to set up an internet connection on an OpenWrt based router to
connect to my ISP which is Tango (Fiber). I have an "Intertek"-branded ONT
(Model G-010G-A) which was installed by Post
So far I have not had success.
I believe it's PPPoE, and apart of the user/password, I need to spoof the
mac-address to pretend my router is their crippled Fritz!Box, and use vlan
35.
Not sure though, and maybe there are more settings (access concentrator
maybe?)
Does anyone have experience with this? I am looking for some hints :)
Thanks in advance.
_______________________________________________
Lilux-help mailing
listLilux-help@lilux.luhttps://www.lilux.lu/mailman/listinfo/lilux-help
_______________________________________________
Lilux-help mailing list
Lilux-help(a)lilux.lu
https://www.lilux.lu/mailman/listinfo/lilux-help